首页 交换机技术 华为交换机配置Web网管登录方式,用网页可视化管理交换机

华为交换机配置Web网管登录方式,用网页可视化管理交换机

一、华为交换机web登陆配置 Web网管是一种对交换机的管理方式,它利用交换机内置的Web服务器,为用户提供图形化的操作界面。用户可以从终端通过HTTPS登录到Web网管,对交换机…

一、华为交换机web登陆配置

Web网管是一种对交换机的管理方式,它利用交换机内置的Web服务器,为用户提供图形化的操作界面。用户可以从终端通过HTTPS登录到Web网管,对交换机进行管理和维护,同时也非常方便。

一、配置思路:

1、配置管理IP地址,便于后续通过Web网管登录交换机。

2、加载Web网页文件。

3、配置Web用户并进入Web网管登录界面。

二、配置步骤:

1、配置管理IP地址

<HUAWEI> system-view

[HUAWEI] sysname HTTPS_Server

[HTTPS_Server] vlan 10

[HTTPS_Server-vlan10] quit

[HTTPS_Server] interface vlanif 10 //配置VLANIF10作为管理接口。

[HTTPS_Server-Vlanif10] ip address 103.155.122.1 24 //请根据网络规划进行IP地址的配置以及路由的部署,确保用户终端与交换机之间路由可达。

[HTTPS_Server-Vlanif10] quit

[HTTPS_Server] interface gigabitethernet 1/0/10 //GE1/0/10为使用Web网管登录Switch的PC与Switch相连的物理接口编号,请按照实际现网情况进行选择。

[HTTPS_Server-GigabitEthernet1/0/10] port link-type access //配置接口类型为access。

[HTTPS_Server-GigabitEthernet1/0/10] port default vlan 10 //配置接口加入VLAN 10。

[HTTPS_Server-GigabitEthernet1/0/10] quit

2、加载web文件

在用户视图下执行命令 dir,可以查看交换机自带的Web网页文件名称。

<HUAWEI> system-view

[HUAWEI] sysname HTTPS_Server

[HTTPS_Server] http server load web.7z //加载Web网页文件。此处名为web.7z的Web网页文件仅为示例。

3、开启HTTPS服务

[HTTPS_Server] http secure-server enable //HTTPS服务默认开启,默认情况下用户可以不用配置。如果HTTPS服务被人为关闭,则需要此命令开启。

4、配置Web用户并进入Web网管界面

# 配置Web用户。

[HTTPS_Server] aaa

[HTTPS_Server-aaa] local-user admin password cipher Helloworld@6789

//创建名为admin的本地用户,设置其登录密码为Helloworld@6789。

[HTTPS_Server-aaa] local-user admin privilege level 15 //配置用户级别为15级。

[HTTPS_Server-aaa] local-user admin service-type http //配置接入类型为http,即:Web用户。

[HTTPS_Server-aaa] quit

5、进入Web网管登录界面。

在PC上打开浏览器,在地址栏中输入“https://103.155.122.1”,按Enter键进入Web网管登录界面。

这样就完成了华为交换机的web网管登陆,当然你如果要检查下配置情况,可以使用命令display http server查看。

除了web、ssh管理方式之外,Telnet的管理方式也在中小网络中也有应用,我们也来看下。

二、华为交换机如何配置Telnet远程登陆

在项目中,也需要远程登录和管理交换机,就可以在交换机上配置Telnet服务功能并使用AAA验证方式登录。 我们以华为交换机为例,来配置交换机的远程登陆。

步骤1:从PC1通过交换机Console口登录交换机。

这个上面已经完成了。

步骤2:配置交换机名称和管理IP地址。

<Quidway>system-view

[Quidway] sysname S //更交换机名为Server

[S] interface ethernet 0/0/0 //进入端口0/0/0

[S-Ethernet0/0/0] ip address 10.10.10.10 255.255.255.0 //配置管理 ip地址。

[S-Ethernet0/0/0] quit //返回

步骤3:配置Telnet用户的级别和认证方式。

[S] telnet server enable //开启Telnet功能。

[S] user-interface vty 0 4 //进入VTY 0~VTY 4用户界面视图,同时支持0到4,5个用户在线操作。

[S-ui-vty0-4] user privilege level 15 //配置VTY 0~VTY 4的用户级别为15级。

[Sr-ui-vty0-4] authentication-mode aaa //配置VTY 0~VTY 4的用户认证方式为AAA认证。

注意:

这里弱电君解释下这个AAA认证。 认证方式,有三种:

AAA(同时输入正确的用户名和密码才能登录);

one(不用认证)

password(输入正确的密码就可登录)认证,

可以根据需要选择,所以我们选择AAA。

[S-ui-vty0-4] quit //返回

[S] aaa //进入AAA认证

[S-aaa] local-user admin123 password irreversible-cipher helloworld@6789 //创建名为admin123的本地用户,设置其登录密码为helloworld@6789 。

这里面的,irreversible-cipher弱电君有必要解释下, 表示对用户密码采用不可逆算法进行了加密,使非法用户无法通过解密算法特殊处理后得到明文密码,为用户提供更好的安全保障。

[S-aaa] local-user admin1234 privilege level 15 //配置用户级别为15级。

[S-aaa] local-user admin1234 service-type telnet //配置接入类型为telnet,即:Telnet用户。

[S-aaa] quit

步骤4:从PC2以Telnet方式登录交换机。

以进入Windows运行窗口,并执行相关命令,通过Telnet方式登录交换机,例:telnet 103.155.122.1 24

免责声明:文章内容不代表本站立场,本站不对其内容的真实性、完整性、准确性给予任何担保、暗示和承诺,仅供读者参考,文章版权归原作者所有。如本文内容影响到您的合法权益(内容、图片等),请及时联系本站,我们会及时删除处理。

作者: 小编

没有了

已是最新文章

为您推荐

华为交换机配置snmptrap命令方式

华为交换机配置snmptrap命令方式

## 首先通过telnet链接上华为交换机 system-view ## 配置交换机的读团体名和写团体名为“public...

发表回复

返回顶部